collapse

Advertisement


Author Topic: 7.3 Powerstroke Help  (Read 2369 times)

Offline TommyH

  • Political Topics
  • Trade Count: (0)
  • Sourdough
  • *****
  • Join Date: Oct 2011
  • Posts: 1698
  • Location: Eastside
7.3 Powerstroke Help
« on: October 15, 2019, 10:47:32 AM »
Anybody around the NE have a scan tool/code reader for these diesels? Truck just died while driving last week. No smoke out the tailpipe.. Iíve thrown $300 at it replacing parts and instead of giving more money to the parts store, getting its codes read seems like the best plan lol. Iíve replaced the cps, ipr valve, unplugged the icp....  really frustrating!! I need my truck back!
On top of all this I had to be towed home by a Chevy!!!!!!!  :bash: :chuckle: :bash:

Offline jeffitz

  • Trade Count: (0)
  • Hunter
  • ***
  • Join Date: Oct 2011
  • Posts: 244
  • Location: SW WA
Re: 7.3 Powerstroke Help
« Reply #1 on: October 15, 2019, 11:00:52 AM »
Check the fuse for the fuel bowl heater - ECM/PCM is on same circuit -fuel bowl heater corrodes and shorts out so if thats it then just unplug it and replace fuse
If you're gonna be dumb,you gotta be tough.

Offline TommyH

  • Political Topics
  • Trade Count: (0)
  • Sourdough
  • *****
  • Join Date: Oct 2011
  • Posts: 1698
  • Location: Eastside
Re: 7.3 Powerstroke Help
« Reply #2 on: October 15, 2019, 11:04:43 AM »
Check the fuse for the fuel bowl heater - ECM/PCM is on same circuit -fuel bowl heater corrodes and shorts out so if thats it then just unplug it and replace fuse

Fuel bowl plug is/has been unplugged for a couple years.

Offline huntnphool

  • Chance favors the prepared mind!
  • Political Topics
  • Trade Count: (+6)
  • Legend
  • ******
  • Join Date: Apr 2007
  • Posts: 28442
  • Location: Pacific NorthWest
Re: 7.3 Powerstroke Help
« Reply #3 on: October 15, 2019, 11:23:31 AM »
 Died while driving, BCM.

 Itís inside the drivers front wheel well, Iíd be starting there. :twocents:
The things that come to those who wait, may be the things left by those who got there first!

Offline RockChuck

  • Non-Hunting Topics
  • Trade Count: (0)
  • Longhunter
  • *****
  • Join Date: Jun 2008
  • Posts: 683
Re: 7.3 Powerstroke Help
« Reply #4 on: October 15, 2019, 11:29:36 AM »
Died like you shut the key off or sputtered ran rough and died? Check your valve cover gasket wire harness/plugs. Injector wiring runs through there and they like to melt at the plug

Offline TommyH

  • Political Topics
  • Trade Count: (0)
  • Sourdough
  • *****
  • Join Date: Oct 2011
  • Posts: 1698
  • Location: Eastside
Re: 7.3 Powerstroke Help
« Reply #5 on: October 15, 2019, 11:36:41 AM »
Died while driving, BCM.

 Itís inside the drivers front wheel well, Iíd be starting there. :twocents:

BCM? Or IDM? It rained earlier that day also...

Died like you shut the key off or sputtered ran rough and died? Check your valve cover gasket wire harness/plugs. Injector wiring runs through there and they like to melt at the plug

No sputtering or nothing, just was driving along and then had no throttle.. pushed the clutch in and lost power steering and brakes.. put it back into 6th and let the clutch out and had power steering and brakes again as motor was turning. 

Offline jeffitz

  • Trade Count: (0)
  • Hunter
  • ***
  • Join Date: Oct 2011
  • Posts: 244
  • Location: SW WA
Re: 7.3 Powerstroke Help
« Reply #6 on: October 15, 2019, 11:40:44 AM »
Ok then its beyond me - the only time mine has died in 20years / 350,000 miles it was the fuel bowl heater shorted and blew that fuse
If you're gonna be dumb,you gotta be tough.

Offline huntnphool

  • Chance favors the prepared mind!
  • Political Topics
  • Trade Count: (+6)
  • Legend
  • ******
  • Join Date: Apr 2007
  • Posts: 28442
  • Location: Pacific NorthWest
Re: 7.3 Powerstroke Help
« Reply #7 on: October 15, 2019, 11:46:19 AM »
Died while driving, BCM.

 Itís inside the drivers front wheel well, Iíd be starting there. :twocents:

BCM? Or IDM? It rained earlier that day also...

Died like you shut the key off or sputtered ran rough and died? Check your valve cover gasket wire harness/plugs. Injector wiring runs through there and they like to melt at the plug

No sputtering or nothing, just was driving along and then had no throttle.. pushed the clutch in and lost power steering and brakes.. put it back into 6th and let the clutch out and had power steering and brakes again as motor was turning.

 Sorry, IDM in the wheel well. They are sealed so I seriously doubt it was rain related. Mine did the same thing once, driving down the highway and it just died, no hiccup or warning of any kind, just died.

 Iíve had the injector harness issue before as well, Iíve never heard of both harnesses going back at the same time, itís typically one side or the other, which will still allow half the engine to run, so I doubt itís the harness.

 Even a fuel issue likely would have given you some sort of warning, a hiccup or surge right before going out.

 My bet is the module, let us know what you find.
The things that come to those who wait, may be the things left by those who got there first!

Offline RockChuck

  • Non-Hunting Topics
  • Trade Count: (0)
  • Longhunter
  • *****
  • Join Date: Jun 2008
  • Posts: 683
Re: 7.3 Powerstroke Help
« Reply #8 on: October 15, 2019, 11:54:16 AM »
Ah yes true on the harness, mine would run but only one side

Is it chipped?
« Last Edit: October 15, 2019, 12:15:01 PM by RockChuck »

Offline Griiz

  • Non-Hunting Topics
  • Trade Count: (+1)
  • Scout
  • ****
  • Join Date: Oct 2012
  • Posts: 253
  • Location: Puget Sound
  • Groups: RMEF
Re: 7.3 Powerstroke Help
« Reply #9 on: October 15, 2019, 12:04:45 PM »
Have you checked the camshaft position sensor? I keep one in my glove box as they are known to fail.

Offline TommyH

  • Political Topics
  • Trade Count: (0)
  • Sourdough
  • *****
  • Join Date: Oct 2011
  • Posts: 1698
  • Location: Eastside
Re: 7.3 Powerstroke Help
« Reply #10 on: October 15, 2019, 12:09:23 PM »
Ok then its beyond me - the only time mine has died in 20years / 350,000 miles it was the fuel bowl heater shorted and blew that fuse

Ya before this happened, the only time mine had died was when the fuel bowl shorted and blew the fuse..

Also I have been stalling on replacing my glow plugs, on cold mornings it takes a few cycles to fire up but always has... usually have a SES light turn on following cold/hard start that will eventually turn off after I drive 5-10 minutes.... gutless while the light is on but as soon as it turns off you can feel full power come back. I was hoping the SES light and lack of power were due to glow plugs being bad, but not sure a bad glow plug or 2 would throw the SES light...? Also didnít think my glow plug issues would effect the truck for 10-15 minutes after it was running..  so that had me thinking possible bad injector or O-ring...?  I think these are unrelated to my no start/no smoke out the pipe issues but not 100% sure especially if itís an injector....???

Offline Fl0und3rz

  • Political Topics
  • Trade Count: (+7)
  • Legend
  • ******
  • Join Date: Oct 2010
  • Posts: 34461
  • Location: E. WA
Re: 7.3 Powerstroke Help
« Reply #11 on: October 15, 2019, 12:11:23 PM »
If it's OBDII, I have a scanner you can borrow if it is nearby.

Offline TommyH

  • Political Topics
  • Trade Count: (0)
  • Sourdough
  • *****
  • Join Date: Oct 2011
  • Posts: 1698
  • Location: Eastside
Re: 7.3 Powerstroke Help
« Reply #12 on: October 15, 2019, 12:14:29 PM »
Have you checked the camshaft position sensor? I keep one in my glove box as they are known to fail.

Yes I started with replacing that first as it was the cheapest and known to fail.  But (I knew better) I didnít buy the OEM and picked up one from autozone...

Offline huntnphool

  • Chance favors the prepared mind!
  • Political Topics
  • Trade Count: (+6)
  • Legend
  • ******
  • Join Date: Apr 2007
  • Posts: 28442
  • Location: Pacific NorthWest
Re: 7.3 Powerstroke Help
« Reply #13 on: October 15, 2019, 12:23:24 PM »
Ok then its beyond me - the only time mine has died in 20years / 350,000 miles it was the fuel bowl heater shorted and blew that fuse

Ya before this happened, the only time mine had died was when the fuel bowl shorted and blew the fuse..

Also I have been stalling on replacing my glow plugs, on cold mornings it takes a few cycles to fire up but always has... usually have a SES light turn on following cold/hard start that will eventually turn off after I drive 5-10 minutes.... gutless while the light is on but as soon as it turns off you can feel full power come back. I was hoping the SES light and lack of power were due to glow plugs being bad, but not sure a bad glow plug or 2 would throw the SES light...? Also didnít think my glow plug issues would effect the truck for 10-15 minutes after it was running..  so that had me thinking possible bad injector or O-ring...?  I think these are unrelated to my no start/no smoke out the pipe issues but not 100% sure especially if itís an injector....???

 How many miles? Itís likely injector time. ;)

 Does it fire right up if plugged in at night?
The things that come to those who wait, may be the things left by those who got there first!

Offline TommyH

  • Political Topics
  • Trade Count: (0)
  • Sourdough
  • *****
  • Join Date: Oct 2011
  • Posts: 1698
  • Location: Eastside
Re: 7.3 Powerstroke Help
« Reply #14 on: October 15, 2019, 12:27:03 PM »
Ok then its beyond me - the only time mine has died in 20years / 350,000 miles it was the fuel bowl heater shorted and blew that fuse

Ya before this happened, the only time mine had died was when the fuel bowl shorted and blew the fuse..

Also I have been stalling on replacing my glow plugs, on cold mornings it takes a few cycles to fire up but always has... usually have a SES light turn on following cold/hard start that will eventually turn off after I drive 5-10 minutes.... gutless while the light is on but as soon as it turns off you can feel full power come back. I was hoping the SES light and lack of power were due to glow plugs being bad, but not sure a bad glow plug or 2 would throw the SES light...? Also didnít think my glow plug issues would effect the truck for 10-15 minutes after it was running..  so that had me thinking possible bad injector or O-ring...?  I think these are unrelated to my no start/no smoke out the pipe issues but not 100% sure especially if itís an injector....???

 How many miles? Itís likely injector time. ;)

 Does it fire right up if plugged in at night?

Yes if plugged in it fires up great. Well it did before this...

 


* Advertisement

* Recent Topics

How Wide is he by M_ray
[Today at 02:33:10 AM]


Hanson Fish Co Group Buy #4 - Delivery Schedule by Skillet
[Today at 01:11:35 AM]


Rookie Elk Hunting Questions by STIKNSTRINGBOW
[Today at 12:19:37 AM]


Tree Cambium by STIKNSTRINGBOW
[Yesterday at 11:49:10 PM]


Wtb: anyone selling a Christensen arms by Bowsnbulls
[Yesterday at 11:45:49 PM]


Kinda cold in my bag by Gobble Doc
[Yesterday at 11:39:39 PM]


80% Jig by Katmai Guy
[Yesterday at 11:11:22 PM]


Hunters Specialties Decoy Pack-Bag by Hairhunter
[Yesterday at 11:07:34 PM]


Christensen arms question? by smdave
[Yesterday at 10:36:18 PM]


Swarovski binos by blackveltbowhunter
[Yesterday at 10:23:12 PM]


WTB: Knight Bighorn stock by steeleywhopper
[Yesterday at 10:06:28 PM]


Machias's 2019/2020 Season by Machias
[Yesterday at 09:57:39 PM]


Operation Bobcat by Bango skank
[Yesterday at 09:47:08 PM]


2019 Gov Whitetail Tag by Benny
[Yesterday at 09:46:19 PM]


Great morning!!! by Birdguy
[Yesterday at 09:43:53 PM]


Trapperguy22 and Bigshooter trapping 2019-2020 by Bigshooter
[Yesterday at 09:40:09 PM]


2019/2020 scoreboard! by Bigshooter
[Yesterday at 09:35:19 PM]


Last day whitetail anyone? by SpurInSpokane
[Yesterday at 09:08:15 PM]


2019 HuntWA Christmas Gift Exchange "List" by HUNTINCOUPLE
[Yesterday at 09:07:16 PM]


Free camper by HighlandLofts
[Yesterday at 09:02:58 PM]