collapse

Advertisement


Author Topic: Scope mounting issue  (Read 1043 times)

Offline shmacker

  • Non-Hunting & Covid-19 Topics
  • Trade Count: (+4)
  • Hunter
  • ***
  • Join Date: Jan 2015
  • Posts: 114
  • Location: Renton
Scope mounting issue
« on: August 15, 2021, 10:01:07 AM »
I recently purchased an x-bolt Hells canyon speed and leupold vx3-hd with Talley x-bolt rings, and cannot get the scope zeroed.  I have the elevation bottomed out and the crosshairs are still high.  Contacted Talley and leupold, and Talley sent a new set of rings to try out but I have the same result.  Even swapping the rear and front rings doesnít get my crosshairs on the bullseye.  Has anyone else had this issue or any insight on how to correct this?

Online Farmer72

  • Trade Count: (+5)
  • Hunter
  • ***
  • Join Date: Jan 2021
  • Posts: 173
  • Location: Port Orchard, WA
Re: Scope mounting issue
« Reply #1 on: August 15, 2021, 10:31:27 AM »
Is the base a 20 MOA? If it is you may want to go to a 0 MOA.

Offline buckfvr

  • Washington For Wildlife
  • Trade Count: (+6)
  • Frontiersman
  • *****
  • Join Date: Jun 2010
  • Posts: 3692
  • Location: PREDATOR PIT UNIT 121
Re: Scope mounting issue
« Reply #2 on: August 15, 2021, 10:33:28 AM »
First thing confirm you have full range of adjustment by turning it all the way each direction, then leave it centered.  Ensure scope is not over torqued as if its too tight it can prevent adjustments from fully operating.  If you dont have an inch lbs torque driver, borrow or get one.  Mount scope as low as possible, leaving minimal barrel clearance, 1/8th in or so.  Maybe post up pic of scope/rifle.

Online 10thmountainarcher

  • Non-Hunting & Covid-19 Topics
  • Trade Count: (0)
  • Longhunter
  • *****
  • Join Date: Oct 2010
  • Posts: 797
  • Location: Buckley
Re: Scope mounting issue
« Reply #3 on: August 15, 2021, 10:49:04 AM »
Is the base a 20 MOA? If it is you may want to go to a 0 MOA.

Looks like the Talley Rings mount directly to the rifle and he opted to got without the rail.

Offline shmacker

  • Non-Hunting & Covid-19 Topics
  • Trade Count: (+4)
  • Hunter
  • ***
  • Join Date: Jan 2015
  • Posts: 114
  • Location: Renton
Re: Scope mounting issue
« Reply #4 on: August 15, 2021, 11:39:08 AM »
Yes they are the low one-piece lightweight rings with no base.  I have the FAT torque wrench and torqued to manufacturer specs.  After talking to leupold, they said that it bottoming out after two full revolutions is the standard range for the scope.  Really scratching my head here.

Offline 10mmg

  • Trade Count: (0)
  • Hunter
  • ***
  • Join Date: Jun 2018
  • Posts: 194
Re: Scope mounting issue
« Reply #5 on: August 15, 2021, 12:12:30 PM »
what caliber and range are you trying to zero to??

Offline shmacker

  • Non-Hunting & Covid-19 Topics
  • Trade Count: (+4)
  • Hunter
  • ***
  • Join Date: Jan 2015
  • Posts: 114
  • Location: Renton
Re: Scope mounting issue
« Reply #6 on: August 15, 2021, 12:20:34 PM »
Itís a .270 and I would like to zero at 100 or 200 but I canít even get it bore sighted at 50yds.

Offline buckfvr

  • Washington For Wildlife
  • Trade Count: (+6)
  • Frontiersman
  • *****
  • Join Date: Jun 2010
  • Posts: 3692
  • Location: PREDATOR PIT UNIT 121
Re: Scope mounting issue
« Reply #7 on: August 15, 2021, 12:29:38 PM »
I think for it to be on at 200, youd want it to be about 1" low at 25.....in years past, I did the dead on @ 25 thing for my .270 and it was back dead on past 225.   Try that and see if you can get it started @ 25 yards.

Offline craigapphunt

  • Trade Count: (+2)
  • Tracker
  • **
  • Join Date: Jul 2015
  • Posts: 67
  • Location: centralia, wa
Re: Scope mounting issue
« Reply #8 on: August 15, 2021, 12:38:58 PM »
It sounds like you've confirmed full range of elevation through the mechanism of the scope but could the scopes zero stop (if equipped) be preventing you from zeroing you rifle?

Offline craigapphunt

  • Trade Count: (+2)
  • Tracker
  • **
  • Join Date: Jul 2015
  • Posts: 67
  • Location: centralia, wa
Re: Scope mounting issue
« Reply #9 on: August 15, 2021, 01:06:16 PM »
Also you stated the cross hair was high did you come to this conclusion via bore sight or by actually firing the rifle?

Online fishngamereaper

  • Trade Count: (+3)
  • Old Salt
  • ******
  • Join Date: Oct 2011
  • Posts: 5810
  • Location: kitsap
Re: Scope mounting issue
« Reply #10 on: August 15, 2021, 01:34:50 PM »
If your using lowest mounts, bottomed out, and still not finding your zero at a 100 I would get a new scope.

Or...

Not super familiar with that scope. Does it have an adjustable zero stop. I had to pull the turret apart on my Ziess and change the zero stop to reset it's revolution range. . It's mounted on an xbolt with Talley rings.

Offline callturner

  • Trade Count: (+1)
  • Scout
  • ****
  • Join Date: Jun 2020
  • Posts: 338
  • Location: nine mile falls Washington
    • n/a
  • Groups: nra
Re: Scope mounting issue
« Reply #11 on: August 15, 2021, 02:29:32 PM »
I just went thru the same problem. Those rings fit a short action fine. I have the same rifle in 6.5 creedmoor.  (short action) . I also have a long action xbolt in 338 win mag. I spoke with Leupold tech and he gave me these #'s - X-BOLT 20-moa 176397  for the base . And 30mm rings # 175120. If you have a 1 in scope tube call and get the correct #.

Offline shmacker

  • Non-Hunting & Covid-19 Topics
  • Trade Count: (+4)
  • Hunter
  • ***
  • Join Date: Jan 2015
  • Posts: 114
  • Location: Renton
Re: Scope mounting issue
« Reply #12 on: August 16, 2021, 10:47:18 AM »
Thanks for all the replies, I spoke with Talley and leupold today and the options were a 20 MOA rail or shims from leupold.  Going to give the shims a shot and see if it fixes the issue.

Offline callturner

  • Trade Count: (+1)
  • Scout
  • ****
  • Join Date: Jun 2020
  • Posts: 338
  • Location: nine mile falls Washington
    • n/a
  • Groups: nra
Re: Scope mounting issue
« Reply #13 on: August 16, 2021, 11:34:40 AM »
Gonna put mine on the bench in the morning, I'll let ya know the results. Mike. :tup:

Offline callturner

  • Trade Count: (+1)
  • Scout
  • ****
  • Join Date: Jun 2020
  • Posts: 338
  • Location: nine mile falls Washington
    • n/a
  • Groups: nra
Re: Scope mounting issue
« Reply #14 on: August 21, 2021, 05:07:04 PM »
Finally got to the bench and the rings and base worked perfect for me. :IBCOOL:

 


* Advertisement

SimplePortal 2.3.7 © 2008-2021, SimplePortal